[教學] Xposed 簡易安裝流程 (Android 5.0/5.1/6.0 Lollipop/Marshmallow)

/ 分類: , / 2 則回應

標籤: ,

會需要安裝 Xposed 框架通常不外乎是想要使用符合需求,像是 Amplify, Greenify, GravityBox, MinMinGuard 等 Xposed 模組,趁著幫手機切換到不同第三方韌體的時間點,記錄一下操作流程,由於網路上對於 Xposed 架構介紹已經很多,本文著重在安裝需求、流程以及注意事項,儘管作者有說明理論上可以適用不同的韌體(沒修改太多的話),不需要額外對韌體本身做修改,但是第三方韌體版本眾多,如果在安裝過程中出問題,可以自行洽詢原作者,或者到各大論壇尋找解決方式。

若是有使用 Systemless Xposed 框架的需求,可另外參考 [教學] Magisk Systemless Interface 簡易安裝流程 (含 Root、Xposed) 一文。

安裝基本需求

  • 要安裝的 Android Device 韌體版本為 5.0 含以上版本
  • 要安裝的 Android Device 已經有取得 root 權限
  • 要安裝的 Android Device 已經有安裝第三方 Recovery (例如 TWRP, CWM 等)
  • 啟用 Android Device 設定\安全性\不明的來源 (用來安裝 Xposed 管理模組 apk)

安裝軟體需求

  • 軟體名稱 : XposedInstaller_3.0-alpha4.apk
  • 軟體用途 : 用來管理 Xposed 模組,需先安裝 Framework (SDK),無法獨立運作
  • 下載連結 : http://goo.gl/Q6Q0WT
  • 軟體名稱 : xposed-vXX-sdkXX-XXX.zip
  • 軟體用途 : Xposed Framework 框架主體,支援處理器包含 arm, arm64 以及 x86 架構,而 sdk 對應韌體版本分別為 SDK21 (Android 5.0 Lollipop), SDK22 (Android 5.1 Lollipop) 以及 SDK23 (Android 6.0 Marshmallow),使用者可針對手邊需求下載對應檔案,若不確定可在手機安裝 Droid Hardware Info 快速辨別
  • 下載連結 : http://dl-xda.xposed.info/framework/

安裝軟體需求 (特定廠牌手機彙整)

部分手機可能因為使用處理器架構或者韌體關係,並無法直接使用官方釋出的相關檔案,以下是彙整網路上針對特定廠牌手機修改釋出的討論串,提供做為參考,在安裝上大同小異,只是需要下載 MOD 過後的檔案

安裝 Xposed Framework (Step 1.)

  • 將 xposed-vXX-sdkXX-XXX.zip 下載至內部儲存媒體
  • 切換至 Custom Recovery Mode,並刷入 .zip (上圖以TWRP為例)
  • 重新啟動手機

安裝 Xposed Installer (Step 2.)

  • 確認已於 設定\安全性\不明的來源 設置為啟用來安裝 APK
  • 開啟檔案管理軟體並執行 XposedInstaller_3.0-alpha4.apk 進行安裝


  • 於安裝完畢後開啟 Xposed Installer
  • 點擊框架,看到 active 綠色字樣就代表安裝成功

  • 進入下載區即可搜尋需要的模組進行安裝使用

一般留言 (2)

  1. To 小編:
    Samsung Galaxy Note3(SM-N900)經過本人測試後,是無法使用Xposed的!!

    • 謝謝你的分享,不過手機是否能夠支援,其實還是受限廠牌韌體,只能反應給原作者了

發表迴響